vSphere 6.5 “Insufficient configured resources to satisfy the desired vSphere HA failover level on the cluster”

EDIT – Today (7/5), VMware GSS confirmed this is a bug that will be addressed in the next patch release.

Problem

Setting up a simple vSphere 6.5 (vCenter build 5178943) environment, using percentage-based HA we have been seeing the following Configuration Issue flag on the cluster (note, it is NOT an alarm!):

Insufficient configured resources to satisfy the desired vSphere HA failover level on the cluster

Screenshot:

You can see the alarms have Acknowledge/Reset options, this is a Configuration Issue message instead.

Possible Solutions

Doing some research I’ve collected the following things people said resolved this:

  • Turn on, or turn off Proactive HA and then disable HA on the cluster, then re-enable HA
  • Verify no firewall is interfering with HA
  • Use various methods to reset FDM on the hosts – disconnect/reconnect, move into another cluster, so on…
  • Set AC percentage to a different, low value (10% CPU/Memory)

In our case, for 3 clusters across 3 vCenters, none of those options worked.  Instead:

  • Disable “Override calculated failover capacity.”

That worked, as a workaround.  Unfortunately, setting ANY value (1%, 10%, 33%, 100%) for percentage based AC causes the config issue.  When I disable Override, the calculated value is 33% as expected.  So, it has to do with manually specifying a value, rather than the particular value specified.

Working Configuration, for a 3-node cluster:

This throws a configuration issue:

Hope that helps.